Introduction to SAS
Getting SAS


See Marielle
Getting help in SAS

· Self help books 

· Available from Marielle

· Online (web)

· See Dr. Hanley’s website for links: http://www.epi.mcgill.ca/hanley/
· Online (online help)

· Need to know what proc you want

· Help > Books and Training > SAS Online Doc

· Help > Books and Training > SAS Online Tutor

(Adapted from document on Dr. Hanley’s website.)

Basics

SAS is orgainized in three windows:  Program editor, Log, and Output.

· Programs are created in the Program editor, then submitted.  These can be saved as .sas files.
· Log:  will tell you which, if any, errors were created when the program ran. Look for the red text.  

· Output:  will contain the results of your program

Can be saved by clicking File > Save As when in the window.

Getting your data into SAS

· Usually get data in excel or text file, must transform this into a sas dataset (.sas7bdat).

·  Import wizard ( very easy if data is in excel
· File > Import data…
·  Using INFILE in a data step * reccommended *
·  Listing the raw data in the data step 
· If you have trouble see Sas Help> Books and Training> SAS Online Tutor
The data step

· What is it?

· To create a data set 
· Within the data step you can:

· To modify or create variables

· To select a subsection of your subjects

 Examples 
· Using infile in data step
data mydata;

input id age sex smoking weight;

infile 'c:\andrea\data1.txt';

run;
· Listing the raw data in the data step
data heart;

input id age sex smoking weight height dbp ;

lines;

1 45 0 0 45 1.25 135
2 43 1 0 32 1.42 140
3 59 0 0 37 1.03 129
;

run;

The INPUT Line

INPUT age gender height weight ;  
 
If you wanted to tell SAS that age was always in columns 1-2, gender in coulumn 4 etc, you could put
 
INPUT age 1-2 gender 4 height 6-9 weight 11-14; 

 
SAS will assume that variables are numeric. 
If you have a variable containing alpha-numeric data (e.g. if in the raw datafile you had m for male and f for female, you would tell SAS that by saying
 
INPUT age 1-2 gender $ 4 height 6-9 weight 11-14; 
 
  
 

How you get your data into SAS depends on what form the data is in to begin with.

text – fixed fields (i.e. columns)
data heart;

input id 1-4 age 6-7 chol  $ 9-12 sex $ 13;

infile 'a:\andrea\data1.txt';

run;
text – not fixed field, values separated by a space:

data sports;

input name $ district $ points;

infile 'a:\andrea\data1.txt';

run;
text – not fixed field, values separated by a comma:

data sports; 
input name $ district $ points;

infile 'a:\andrea\data1.txt' dlm=',';

run;
Programming statements:

· To create new variables or select a subset
· Used within data steps

Changing sex (entered as m or f) into 0 or 1

if sex=’m’ then newsex=0;

if sex=’f’ then newsex=1;

Creating a new variable:

bmi= height/(weight*weight);

Creating an interaction term:

age_sex=age*sex;

Selecting a group of subjects (subjects over 45 yrs old):

if age > 45;

Logical statements in SAS

Subjects over 45 yrs old or less than 30 yrs old:

if age > 45 or age < 30;

Subjects 45 or more yrs old, who are male:
if age >= 45  and sex=’m’;

Example
data mydata;

infile 'c:\andrea\data1.txt';

input id age sex smoking weight heigh hi_cholt;

run;

mydata will have 7 variables

data mydata2;

set mydata;

bmi= height/(weight*weight);

if age > 45 and sex=0;

run;
mydata2 has 8 variables and only contains men over the age of 45

Storing your data

· Libraries vs. Work folder
Creating a library

Submit the following statement in the program window every time you open sas:

libname course 'C:\My Documents\Course681';

Or (just once):

· Right click in the explorer window

· Select New

· Enter a name for the library (try to make it short and informative)

· Engine: leave as default

· Click enable at startup

· Click browse and select the physical location for this library on your pc’s harddrive

· Click OK

· Accessing data in a library

· Now, when you double click the libraries in the explorer window, you should see the library just created.

· Double clicking on the new library will show which data objects are in the library.

Ex.  I create a library called course
libname course 'C:\My Documents\Course681';

DATA course.body;

infile 'C:\Documents and Settings\andrea.EPIMGH\My Documents\Today\intro to sas\bodyfat2.txt';

INPUT CaseNo Brozek Siri Density Age Weight Height Adiposit FatFreWt Neck Chest Abdomen Hip  Thigh  Knee  Ankle Biceps  Forearm  Wrist;

run;
A data set named body is created in the course library.  The data set is called course.body.
Commenting your programs

· i.e. adding text that explains what you are doing.  Very good habit to take up, makes it much easier to go back to old programs.

· Comments show up as green in the SAS program editor.

· 2 Ways to make comments:

· Start with a * add the comment and end with a ;

*create a dataset containing  older subjects only;
· Start with a /* then the comment then */
/* Density (gm/cm^3) */  
Missing values in SAS

· Missing values are represented by . .  

· When reading your data in, if the data is missing, you should give it a . .

A missing value is considered as less than 0, so that if you sorted 2,4,.,1,0  SAS would return: ., 0,1,2,4

Example

data course.body2;

set course.body;

if 0 <= siri <10 then pctfatcat=0;

if 10 <= siri <15 then pctfatcat=1;

if 15 <= siri <20 then pctfatcat=2;

if 20 <= siri <25 then pctfatcat=3;

if 25 <= siri  then pctfatcat=4;

if age > 35 then agecat=1;

else agecat=0;

run;

*creates a new dataset in the same library which contains all the variables in the original dataset, as well as pctfatcat and agecat; 

*create a dataset containing  older subjects only;
data older;

set course.body2;

if agecat=1;

run;

*create a dataset containing  subjects without agecat missing;
*^= means "not equal", missing values in SAS are represented by . ;
data nomissing;

set course.body2;

if agecat ^= .;

run;

Exploring your data
Proc contents

· Gives you info on which variables exist, number of observations etc.

proc contents data=course.body2;

run;
Proc freq

· Good for categorical variables

· Outputs the number and percent of subjects in each category

*output a table classifying subjects by age category;
proc freq data=course.body2;

tables agecat;

run;

*output a table classifying subjects by age cat and pct body fat;
proc freq data=course.body2;

tables agecat*pctfatcat /nopct nocol norow ;

run;

*saves on typing!;
proc freq data=course.body2;

tables agecat agecat*pctfatcat;

run;
Proc univariate

· Good for continuous variables

· Gives mean, median, min and max observations, percentiles

*get info on continuous variables;
proc univariate data=course.body2;

var age siri;

run;
Proc print

Prints your data, can select specific variables to print.

proc print data=course.body2; 
var caseno age;

run;
Proc corr

· gives correlation of variables

*gives correlations for all pairs of variables listed;
proc corr data=course.body2;

var siri brozek age;

run;

Proc means
·  gives mean, min, max, quantiles of variables

*gives the same info as proc univariate, but less;
proc means data=course.body2;

var siri age weight;

run;

*get means for selected continuous variables in subjects less than 35 and in subjects more than 35;
proc means data=course.body2;

class agecat;

var siri age weight;

run;

Multiple linear regression in SAS
*multiple linear regression;
proc reg data=course.body2;

model siri=age height weight ;

run;

*confidence intervals for parameter estimates;
proc reg data=course.body2;

model siri=age height weight/clb ;

run;

*output type 1 and type 2 sums of squares;
proc reg data=course.body2;

model siri=age height weight /ss1 ss2;

run;

Useful trick: where statement

proc reg data=course.body2; where pctfatcat <3;

model siri=age height weight/clb ;

run;

proc print data=course.body2; where age >= 45;

var siri age height weight ;

run;

MORE ADVANCED TOPICS
Sorting & Merging

proc sort  data=course.mydata;

by age weight;

run;

course.mydata is now sorted by age and weight.

If you have two datasets containing different information on the same subjects (eg. one file with age, sex, weight, and another file with exposure information), both data sets have a patient id variable, you can merge the two data sets as follows:

First, sort them:
proc sort data=demo_data;

by id;

run;

proc sort data=expo_data;

by id;

run;

data all_data;

merge demo_data expo_data;

by id;

run;

Dates & Time in SAS
Adapted from:
SAS > Help> Books & Training > SAS Online Tutor > Learning Paths > Reading Date and Time Values
SAS stores dates as the number of days since January 1, 1960.

So:  

January 1, 1960 : 0

Dates before this: get a negative number

January 1, 1961: 366

January 2, 2000: 14611

Time:  stored as the number of seconds since midnight

Datetime: combines dates and time, it is the number of seconds since midnight, January 1, 1960.

Reading in dates in SAS

	02Jan00
	DATEw.
	14611

	01-02-2000
	MMDDYYw.
	14611

	02/01/00
	DDMMYYw.
	14611

	2000/01/02
	YYMMDDw.
	14611


	Informats determine how data values are read into a SAS data set. These data values can be standard or nonstandard. You must use informats to read numeric values that contain letters or other special characters. 
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Date Expression 

	SAS Date Informat



	

	 101599

MMDDYY6.
 10/15/99

MMDDYY8.
 10 15 99

MMDDYY8.
 10-15-1999

MMDDYY10.



	 Date Expression 
	SAS Date Informat


	

	 30May00

DATE7.
 30May2000

DATE9.
 30-May-2000

DATE11.



Two-Digit Year Values 

When a two-digit year value is read, SAS software defaults to a year within a 100-year span determined by the YEARCUTOFF= system option. 
(Default value of YEARCUTOFF= is 1920.) 

	Date Expression
	Interpreted As

	12/07/41

18Dec15

04/15/30

15Apr95


	12/07/1941

18Dec2015

04/15/1930

15Apr1995




OPTIONS YEARCUTOFF=1900; 

options yearcutoff=1920;

data aprbills;

input id @3 DateIn mmddyy8. @12 DateOut mmddyy8.  RoomRate EquipCost ;

lines;

1 04/05/99 04/09/99 175.00 298.45
2 04/12/99 05/01/99 125.00 326.78
3 04/27/99 04/29/99 125.00 174.24
4 04/11/99 04/12/99 175.00  87.41
5 04/15/99 04/22/99 175.00 378.96
6 04/16/99 04/23/99 125.00 346.28
;

run;

* I used @3 to tell SAS that the DateIn variable started in the 3rd column, the format after DateIn tells SAS what form the variable is in.  @12 tells SAS that DateOut starts at the 12th column;

Some ways to make your output nicer:
proc format

labels

titles

See example below on how to use these.
*makes three new formats;
proc format;

value catft 0 ='[0-10['
           1 ='[10-15['


   2 ='[15-20['


   3 ='[20-25['


   4 ='[25-+';

value contft 0-<10 ='[0-10['
           10-<15= '[10-15['


   15-<20= '[15-20['


   20-<25= '[20-25['


   25-high ='[25-+';

value ageft 0='<=35'
            1='>35'; 

run;

data mylib.body2;

set mylib.body;

*making some categorical variables;
if 0 <= siri <10 then pctfatcat=0;

if 10 <= siri <15 then pctfatcat=1;

if 15 <= siri <20 then pctfatcat=2;

if 20 <= siri <25 then pctfatcat=3;

if 25 <= siri  then pctfatcat=4;

if age > 35 then agecat=1;

else agecat=0;

*label the variable so that more than the variable name appears in the output;
label agecat ='Age Category'
      pctfatcat ='Pct Body Fat as measured by SIRI';

*apply the formats to the variables formats take a . after the format name and turn green in SAS;
format pctfatcat catft. 

      siri contft. 

      agecat ageft. ;

run;

*add titles to the output;
title 'Descriptive Statistics';

title2 'Categorical Variables';

proc freq;

tables pctfatcat*agecat /norow nopct;

run;

proc freq;

tables siri /norow nopct;

run;

*change secondary title;
title2 'Continuous Variables';

proc corr  data=mylib.body2;

var siri agecat;

run;

*take the titles off;
title ;

title2 ;
*notice the titles;

Descriptive Statistics                   11

                     Categorical Variables

                       The FREQ Procedure

                  Table of pctfatcat by agecat

*notice the label describes what pctfatcat is and the format made the categories informative;

            pctfatcat(Pct Body Fat as measured by SIRI)

                        agecat(Age Category)

              Frequency‚

              Col Pct  ‚<=35    ‚>35     ‚  Total

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              [0-10[   ‚     15 ‚     24 ‚     39

                       ‚  23.81 ‚  12.70 ‚

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              [10-15[  ‚     14 ‚     31 ‚     45

                       ‚  22.22 ‚  16.40 ‚

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              [15-20[  ‚     14 ‚     34 ‚     48

                       ‚  22.22 ‚  17.99 ‚

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              [20-25[  ‚     12 ‚     42 ‚     54

                       ‚  19.05 ‚  22.22 ‚

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              [25-+    ‚      8 ‚     58 ‚     66

                       ‚  12.70 ‚  30.69 ‚

              ƒƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆƒƒƒƒƒƒƒƒˆ

              Total          63      189      252

 Descriptive Statistics                  12

 Categorical Variables

                       The FREQ Procedure

                                       Cumulative

                  Siri    Frequency     Frequency

               ƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒƒ

               [0-10[           39            39

               [10-15[          45            84

               [15-20[          48           132

               [20-25[          54           186

               [25-+            66           252
*notice how we used applied a categorical format to a continuous variable, and now can get a proc freq for that variable without creating a new categorical variable;

*notice the titles, and the label on agecat below;

                     Descriptive Statistics                   13

                      Continuous Variables

                       The CORR Procedure

               2  Variables:    Siri     agecat

                       Simple Statistics

 Variable           N          Mean       Std Dev           Sum

 Siri             252      19.15079       8.36874          4826

 agecat           252       0.75000       0.43387     189.00000

                       Simple Statistics

      Variable       Minimum       Maximum    Label

      Siri                 0      47.50000

      agecat               0       1.00000    Age Category

           Pearson Correlation Coefficients, N = 252

                   Prob > |r| under H0: Rho=0

                                  Siri        agecat

            Siri               1.00000       0.23492

                                              0.0002

            agecat             0.23492       1.00000

            Age Category        0.0002
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